SupportJPG
  Support Home   |   Search   |   Documentation
ArticleId = kb000168

PROBLEM: Error "File is busy" or "Access Denied" when trying to update an ActiveX DLL

The information in this article applies to:

    • IIS
    • MTS & COM+
    • Windows
    • ASNA Visual RPG
    • Web
    • Deploy

SYMPTOMS:

You receive the following error message "File is busy" or "Access Denied" when trying to update an ActiveX DLL

CAUSE:

Here are the possible causes:

  • MS IIS InetInfo.EXE Process has the DLL loaded in memory.
  • Your DLL is marked as Read Only. Check your file properties in Windows Explorer (see Figure 1)

NOTE: Any time you copy your files from a CD-R media, they are marked as Read-Only.

Figure 1

RESOLUTION:

Here are the possible resolutions:

  • Stop IIS InteInfo.EXE and Register the ActiveX DLL in MTS / COM+.
  • Change your DLLs file property to not use Read Only.

STATUS:

Current.

MORE INFORMATION:

Microsoft's KB Article: How to Isolate a DLL Into a Separate Process By Using Microsoft Transaction Server (MTS) discusses the method in which to:

  • stop / start InetInfo Process so the DLL can be unloaded from Memory
  • Create an MTS / COM+ Package

Keywords: IIS, Web, busy, denied, deployment, memory, application, read only, read-only, copy, CD

Last Modified Date: 3/21/2003 10:20:47 AM

Copyright © 2005, 2006 ASNA Inc.

  Support Home   |   Search   |   Documentation