SupportJPG
  Support Home   |   Search   |   Documentation
ArticleId = kb000235

PROBLEM: Receiving "Error 913" when attempting to connect to DataGate (DataGate/400 or DataGate for Windows) with Acceler8DB Database Manager

The information in this article applies to:

    • DataGate/400, All Versions connecting with TCP/IP
    • DataGate for Windows and Desktop Servers, Release 7.1 and higher
    • Acceler8DB, Release 5.0 and lower
    • TCP/IP
    • OS/400
    • Windows

SYMPTOMS:

When attempting to connect to DataGate with Acceler8DB Database Manager, an error occurs: "Error 913: The TCP/IP Connection was terminated unexpectedly. The Server was probably shut down".  In addition to the error message no one, nor any ASNA products can connect.

CAUSE:

There are several causes for this error:

  • The version of the client is higher than the version of the DataGate server;
  • There is a configuration on the AS/400 Job Description that is forcing the job to run in a multi-threaded environment.  Any operation the application program attempts on the client will report the proper error:

    dgEiCONNLOST = 913
    The TCP/IP Connection was terminated unexpectedly. The Server was probably shut down

RESOLUTION:

NOTE:  Please coordinate with your System Administrator or IBM regarding changing or modify the Job Description (JOBD).

Here are the possible resolutions:

  • Check the DataGate Server version and compare it with the version of the Acceler8DB/DataGate client. In some instances, the client version is higher than the server version. If this is the case, please upgrade to the latest DataGate server.
  • There is a possibility that the OS/400 job log is full:

Often, the iSeries is set to end a job if its joblog fills up (i.e. gets too many messages in it, or has too much detail - this can happen in a job that runs for a long time). When the user gets the "TCP/IP connection was terminated" message, find their DataGate job...most likely it will be out there with a joblog in it. If the joblog is extremely big and the last message isn't a job completion-type message, the joblog might be getting full forcing the job to end.

  • After reviewing joblog/spoolfile information, there is a message about "the job is capable of having multiple threads.." (See Figure 1).

Figure 1

The Default Job Description (QDFTJOBD) on the AS/400 causes the jobs to run in multi-threaded mode (See Figure 2).

Figure 2

Copy the default job description into a job description that  resides in DataGate/400 library: DG8_40 and name it as DG8JOBD, and changed the multi-threaded mode to *NO and changed the DataGate/400 Service Profile (DG8SVCPRF) to use that new job description (See Figure 3).

Figure 3

Started DataGate/400: DG8_40/STRDG8SVR

MORE INFORMATION:

If you need to force a joblog to see if there is information on the multithreading capabilities, please follow the steps below:

  1. End DataGate/400 Service: DG8_40/ENDDG8SVR (or ASNA_DG8/ENDDG8SVR);
  2. Start DataGate/400 Service: DG8_40/STRDG8SVR (or ASNA_DG8/STRDG8SVR);
  3. Work with each of the DataGate Service Jobs (option 5 after issuing a WRKACTJOB) and display the job definition attributes (option 2);
  4. Press F9 to Change Job;
  5. F10 to Display Additional Parameters;
  6. Scroll down and change the Message Logging attributes, e.g. Level, Severity, Text (See Figure 4);
  7. Then attempt to connect from the client (Database Manager, etc..);
  8. Finally, to view the joblog, work with the spool file for DG8SVCPRF: WRKSPLF DG8SVCPRF.

Figure 4

The AS/400 C runtime notices that the job has the multithreaded flag turned on (the job description caused the flag to be turned on), and uses alternative logic for the exit() function DataGate/400 uses. Anytime exit() is called with this flag turned on, the job will end immediately. DataGate/400 only uses exit() in the routine that is starting the license manager job.

Releated Links:

Keywords: job, terminate, service, Multi-thread, multithreaded, multithread, connect

Last Modified Date: 3/6/2006 9:47:41 AM

Copyright © 2005, 2006 ASNA Inc.

  Support Home   |   Search   |   Documentation