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ArticleId = kb000019

PROBLEM: DataGate/400 Service won’t start, (active only for 1 second)

The information in this article applies to:

    • DataGate/400, All versions with TCP/IP
    • AS/400

SYMPTOMS:

After entering the DG8_40/STRDG8SVR command, no errors are generated, Job Log indicates service started and ended successfully and ran for about 1 second.

CAUSE:

DataGate/400 was running and the AS/400 went down leaving the data area DG8SVCPID in the DG8_40 library.

Another possible cause is that the DataGate/400 JOBQE (Job Queue Entries) were entered without being set to *NOMAX. Please visit our installation instructions for more information: DataGate/400 Installation guide.

RESOLUTION:

Delete the DG8SVRPID data area and start the service again.

If the data area persists, please check the authority on the "/" object. Please review the FAQ on DataGate/400 Security: Permission on "/"

If the data area does not exist, it may be possible that the TCP/IP port that DataGate/400 is attempting to bind to is in use. If so, please review this article to determine if the port is in use:

Port in use

If the port is not in use and the data area does not exist, make sure the DataGate service profile (DG8SVCPRF) is not resotred:

DG8SVCPRF was restored

Make sure the JOBQE are set with *NOMAX.

MORE INFORMATION:

Other ASNA KB Articles:

Keywords: engine, service, job, IPL, crash

Last Modified Date: 4/26/2006 8:09:11 AM

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