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PROBLEM: DataGate/400 Service will not start or Acceler8DB Receives an "Error 90x" when trying to connect to your AS/400 Database.

The information in this article applies to:

    • DataGate/400, All Versions connecting with TCP/IP
    • Acceler8DB
    • AS/400

SYMPTOMS:

These are the symptoms that the DataGate Service is not running on the AS/400:

  • Any Error received from that begin with "Error 90x" (Where "x" is a number.)
  • Upon entering the start command for DataGate, DG8_40/STRDG8SVR and then do a WRKACTJOB, you see no DATAGATE entries running under QINTER (or whichever subsystem you have chosen to run DataGate). You find a printout or a print spool in the QEZJOBLOG that reads, "Error binding socket…"  If you don't see a joblog or spoolfile, please make sure the DataGate/400 Service is running.

Note: On your client machines, the typical error is "Error 903, Can not connect to Database Server" or "Database Server did not respond" when trying to connect to your AS/400 Database through Acceler8DB Manager.

CAUSE:

The port used by DataGate (typically 5042), is in use by another running job.  There are usually several causes for this.

  • The DataGate service was running the last time you shut down the QINTER subsystem without first ending the DataGate service;
  • There is a service or job other than DataGate which is using the port (5042);
  • The configuration of DataGate was not completed or is incorrect (Need ADDJOBQE per DataGate/400 Installation Notes).

RESOLUTION:

NOTE:  Please coordinate with your System Administrator or IBM while working on the AS/400.

  • To correct this situation, do a WRKTCPSTS and select Option 3. Press F14 to see the numeric values on the local ports column. Press F11 to see the User connected to the Port. Under the local ports column find and entry that reads 5042.

If you find that DataGate is using this port, after first verifying that there are no DataGate jobs running, end this entry by entering a 4.

If you find that the port is being used by a different service other than DataGate, then you will have to decide which service keeps the port and assign a different port number to the other service.  If the port in conflict is indeed 5042, then you should probably assign it to DataGate since it has been official registered by ASNA with the Intenet Assigned Numbers Authority, for a list of all assigned ports click here. To change a port number use the command WRKSRVTBLE.

  • Please verify the configuration of DataGate by checking the JOBQE for DG8_SVC and DATAGATE, via the OS/400 Command: WRKJOBQ.  These instructions can be found in the Installation Guide for DataGate, under "Configuring DataGate/400 for TCP/IP Access".

After you have resolved the conflict enter the DataGate start service command:

DG8_40/STRDG8SVR

PREVENTION:

To prevent this situation, be sure to end the DataGate service before ending the QINTER subsystem and do not assign the same port number to two different services.

The command to end DataGate is:

DG8_40/ENDDG8SVR

  • If you have a Start-up Program, then you need to make sure TCP/IP and QINTER is Started before issuing the Start Service command.
  • If you have a Shutdown Program, then you need to issue the End DataGate Service command prior to ending TCP/IP and QINTER.

MORE INFORMATION:

Other Knowledge Base Articles you may want to refer to:

Keywords: deployment, client, connection, service, engine

Last Modified Date: 8/29/2002 2:15:11 PM

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