SupportJPG
  Support Home   |   Search   |   Documentation
ArticleId = kb000243

PROBLEM: Receiving "Error 1205: Invalid or missing ADB Server License" when attempting to connect to DSS 5.0 Server from a DSS 7.x Client

The information in this article applies to:

    • ASNA Visual RPG, Release 4.0 and higher
    • DataGate for SQL Server for .NET, Release 7.1 and higher
    • MS SQL Server 2000 and MS SQL Server 2005

SYMPTOMS:

After installing or upgrading the following products:

  • AVR for .NET 7.1 and higher
  • AVR 4.1
  • Monarch
  • DataGate for SQ Server for .NET 7.x
  • DataGate Component Suite for .NET 7.x
while AVR 4.0 is installed on the same machine, clients attempting to connect to DSS 5.0 Server will receive the following error:

Error 1205: Invalid or missing ADB Server License

CAUSE:

The target server does not have a valid DataGate for SQL for .NET 7.x License.

STATUS:

Current.

RESOLUTION:

Please contact your sales executive or ASNA's licensing department: codes@asna.com for a DataGate for SQL 7.x License.

MORE INFORMATION:

You can not have a 5.0 client (i.e.: adbcom.dll and adbapi.dll) access DSS 7.x Server (Engine); additionally, you can not have a 7.x client (i.e.: adbcom.dll and adbapi.dll) access a DSS 5.0 Server (Engine), i.e. the client and the server have to be at the same release level. Please visit the following link:

HOWTO: AVR 4.x Applications accessing DataGate for SQL Server 7.x

Keywords: SQL, DSS, Deploy, error 1205, license, compatibility, requirements

Last Modified Date: 3/6/2006 10:09:20 AM

Copyright © 2005, 2006 ASNA Inc.

  Support Home   |   Search   |   Documentation