SupportJPG
  Support Home   |   Search   |   Documentation
ArticleId = kb000067

PROBLEM: Receiving error "Database not available or does not exist" while opening database.

The information in this article applies to:

    • Acceler8DB, Release 4.6 and higher
    • Windows
    • Deploy

SYMPTOMS:

Here are possible symptoms for "Error 610: Database not available or does not exist":

  • While trying to open database with database manger;
  • Database manager is failed while attempting to repair the catalog;

CAUSE:

Here are some possible causes:

  • The server could not open the database because one of the catalog files does not exists or can not be recovered.  While recovering the indices of a file, it is necessary to create work files in the windows temporary directory, if there is no space available in the drive of  the temporary directory, then the recovery will fail.
  • Acceler8DB was in the middle of disk I/O and a power failure has occurred on a Windows Server with FAT file system.  Upon rebooting, the Server tried to repair the hard disk, causing some file corruption. Please visit the installation requirements for ADB and AVR in the More Information Section.
  • A database catalog file is marked "read-only".

RESOLUTION:

Note: Please coordinate with your Network Administrator or Microsoft to change any Windows settings.

Here are possible resolutions:

  • The problem is due to insufficient disk space you can either try to make room on the disk. You may also want to point the temporary directory to a different drive. The temporary directory is specified to Windows by setting an environmental variable.  If there is sufficient disk space, please contact technical support;
  • Restore your database from a recent backup;
  • Make sure none of the files that comprise the database in Windows Explorer are not marked as read-only, if they are, then change them to not be read-only.

MORE INFORMATION:

Environmental variables are set in Windows 95/98 in the autoexec.bat file.

On Windows NT, 2000, and XP, you set it in the machine Properties dialog reachable from the right mouse menu on the My Computer icon of the desktop.  There are actually 2 environmental variables for the temporary directory, one called TMP and the other one TEMP.   Set both to point to the same location.

Other ASNA KB Articles:

Keywords: database, exists, directory, open, error, environment, deployment, client, 107

Last Modified Date: 12/11/2001 4:25:37 PM

Copyright © 2005, 2006 ASNA Inc.

  Support Home   |   Search   |   Documentation