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ArticleId = kb000047

PROBLEM: Receiving error "Invalid user/password, security context not established" while opening database.

The information in this article applies to:

    • Acceler8DB, All Versions
    • Windows

SYMPTOMS:

While trying to open database with Acceler8DB database manger, Acceler8 DB reports:

   Unable to open database, invalid user/password
   security context not established, Error 11

CAUSE:

The server did not recognized the user account being used as a valid account or the password is invalid. The account and password must be valid and active for the Windows Domain.

RESOLUTION:

  • If the password is wrong or has expired, you will need to specify the correct password for this database name in the Work with Database Names dialog, accessible from the Database menu of Acceler8DB Database Manager.  (You may need to contact your Network Administrator to reset your password if your having problems resetting your password.)

    kb000047-2.gif (8162 bytes)

  • The User ID Account may not be recognized for several reasons and these depend on:
    • Who is signed on at the client machine (See Item #1 listed below);
    • The configuration of the Account to Use on Server in Acceler8DB Work with Database Names (See Item #2 listed below);
    • How the server and network have been configured (See Item #3 listed below).

    1. Please verify when the user logs into a client machine, they used a valid and active User ID that verifies the account.
    2. For example:  A user is presented with a Windows Login Screen.  They enter their User ID and Password.  In most instances, there will be a Domain Name where they verify their User ID.

      If there is no Domain present or if it is the same name as their computer, then the login will be local to their computer and the User ID account that they are using is going to be on the local machine.

    3. Please verify the configuration settings in Acceler8DB Manager's Work with Database Names:
      • If the client is logging into a Domain or the Local machine, then we recommend the default setting (*DOMAIN) in the Username field when working with Acceler8DB Work with Database Names:

        kb000047-3.gif

        This setting will allow Acceler8DB Manager to take the information at initial client login, which is discussed above in Item#1, (such as: User ID; Password; Domain Name) and send that information to the Network Server to validate where the Domain User ID Accounts are stored.

        NOTE: If you are connecting to a remote Acceler8DB database on a Windows Server, and you are logged into your machine using the local computer name rather than the Domain name, then your client is not being authenticated by the domain.  If this is the case, then you can not use *DOMAIN and you will have to specify the "domain name\user name" (see the item below).

      • If you can't or don't want to use *DOMAIN or if the problem still persists, then when you are specifying the Account to use on Server, you will need:

        [DOMAIN NAME]\[USER NAME]

        [PASSWORD]

        Where:

        • [DOMAIN NAME] is the Domain Name for your Network;
        • [USER NAME] is the User Name for your User.
      • If neither of the items mentioned above fix the problem, then you will need to specify the computer where the User ID Account is stored, when working with the Account to use on Server:

        [SERVER NAME]\[USER NAME]

        [PASSWORD]

        Where:

        • [SERVER NAME] is the Server Name of the Computer;
        • [USER NAME] is the User Name for your User.
    4. The next thing to determine is the Server and Network Configuration.  Please check the account under which the Acceler8DB Server is running.   Using the Services Dialog from the Control Panel of Windows NT, press the Startup... button and examine the settings for the Acceler8DB Server service:

      The most common (DEFAULT) setting is to have the System Account run the service, but your Administrator may have set it up to run under a particular account.

      Note: To get to the Services Dialog in Windows 2000 and XP, you will need to go to Control Panel --> Administrative Tools --> Services. In Windows NT, 2000, and XP Professional, you will need to be logged on with Administrative privileges in order to verify settings and to stop / start Services. Please check with your Network Administrator for more information.

    kb000047-1.jpg (21357 bytes)

    MORE INFORMATION:

    • For the sake of this article, let us discuss some possibilities in which a user will get an Error 11 or if the connection is successful. Let us assume the following:

        Server Name : Everest
        Server Domain : Lake
        Acceler8DB Service User ID Account: Piston

        Also, there are other Domains within your network. (Lake has a trust relationship with Shaft. Shaft does not have a trust relationship with Spark):

    • Shaft
    • Spark
    • The 1st column of the next table shows the Username specified on the Database Name on the client PC.
    • The 2nd column represents a server running under the System Account.
    • Finally the 3rd column shows a server running under a specific account (Lake\Piston).

      On each cell of the 2nd and 3rd columns, we find the actual account used when connecting to the database server.

      Username on Acceler8 Database Name System Account Lake\Piston
      *Domain (Lake\Joe signed on) Lake\Joe Lake\Joe
      *Domain (No account specified at sign on) Error 11 Error 11
      User1 Everest\User1 Lake\User1
      Piston\User2 Piston\User2 Piston\User2
      Shaft\User3 Shaft\User3 Shaft\User3
      Spark\User4 Error 11 Error 11

Other ASNA KB Articles:

Other Microsoft Articles:

Keywords: Security, user, password, 11, context, name, database, account

Last Modified Date: 12/13/2001 8:51:36 AM

Copyright © 2005, 2006 ASNA Inc.

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